CHAI3DCHAI3D

Error building latest chai3D relese on VS2013

More
05 Jun 2017 09:48 #7

I am getting the same issue even after importing the glfw project and changing the dependency of myProject to chai3d and glfw.

There are 51 errors and the main error which should be resolved to resolve other error is the header file of glfw.

Errors:
Error 1 error C1083: Cannot open include file: 'GLFW/glfw3.h': No such file or directory D:\projects\application\myProject\myProject\main.cpp 47 1 myProject

2 IntelliSense: cannot open source file "GLFW/glfw3.h" d:\projects\application\myProject\myProject\main.cpp 47 1 myProject

3 IntelliSense: identifier "GLFWwindow" is undefined d:\projects\application\myProject\myProject\main.cpp 127 1 myProject


and so on all the error is related to GLFW header file

Please Log in or Create an account to join the conversation.

More
07 Nov 2017 19:44 #8

I was having the same error.
You can just use the relative path as the include path instead:

#include "..\..\external\CHAI3D\extras\GLFW\include\GLFW\glfw3.h"

It looks like the tutorial is missing out on one include-directory setting:

Add the following directories:

../../external/CHAI3D/src
../../external/CHAI3D/external/Eigen
../../external/CHAI3D/external/glew/include
../../external/CHAI3D/extras/freeglut/include
Please note that the last directory is only used if you are using FreeGLUT as the display library. If you are using another framework such as .NET or Qt, then this line can be ommited and replaced by other references.


The line that is missing:

../../external/CHAI3D/extras/GLFW/include

So you can use the relative path or add this include path in the settings.

Please Log in or Create an account to join the conversation.

More
15 Nov 2017 13:59 #9

Thank you for the note!

Please Log in or Create an account to join the conversation.